summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMark McLoughlin <markmc@redhat.com>2012-01-17 15:07:58 +0000
committerMark McLoughlin <markmc@redhat.com>2012-01-17 15:07:58 +0000
commitd72109e7114724de668de24800829b07e0d3fe7e (patch)
tree1d2f40b8a3e3b32faa2482bd49abd21e2de7c8d0 /setup.py
parent2012f1df0859be082f67ee982d5d0d4b6cf2c3d9 (diff)
downloadnova-d72109e7114724de668de24800829b07e0d3fe7e.tar.gz
Add missing scripts to setup.py (lp#917676)
If distutils-extra is installed, all scripts are automatically included in the tarball. We should explicitly include them in setup.py to avoid confusion. As an example, the 2011.3 tarballs appear to have been generated with distutils-extra but the 2011.3.1/2012.1 tarballs are now being generated in a venv. So, these newer tarballs are missing scripts which were included in 2011.3. Change-Id: I2a85418b84b93e041f6c7d31833b09acdcb29daa
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ec3e8e2c7e..f7aec9a36e 100644
--- a/setup.py
+++ b/setup.py
@@ -80,7 +80,10 @@ setup(name='nova',
include_package_data=True,
test_suite='nose.collector',
data_files=find_data_files('share/nova', 'tools'),
- scripts=['bin/nova-ajax-console-proxy',
+ scripts=['bin/clear_rabbit_queues',
+ 'bin/instance-usage-audit',
+ 'bin/nova-ajax-console-proxy',
+ 'bin/nova-all',
'bin/nova-api',
'bin/nova-api-ec2',
'bin/nova-api-metadata',
@@ -97,8 +100,9 @@ setup(name='nova',
'bin/nova-rootwrap',
'bin/nova-scheduler',
'bin/nova-spoolsentry',
- 'bin/stack',
- 'bin/nova-volume',
'bin/nova-vncproxy',
+ 'bin/nova-volume',
+ 'bin/nova-vsa',
+ 'bin/stack',
'tools/nova-debug'],
py_modules=[])