summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 1 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 1276e0aee4..ec784d91f0 100644
--- a/setup.py
+++ b/setup.py
@@ -16,26 +16,12 @@
# License for the specific language governing permissions and limitations
# under the License.
-import gettext
import glob
import os
from setuptools import find_packages
-# In order to run the i18n commands for compiling and
-# installing message catalogs, we use DistUtilsExtra.
-# Don't make this a hard requirement, but warn that
-# i18n commands won't be available if DistUtilsExtra is
-# not installed...
-try:
- from DistUtilsExtra.auto import setup
-except ImportError:
- from setuptools import setup
- print "Warning: DistUtilsExtra required to use i18n builders. "
- print "To build nova with support for message catalogs, you need "
- print " https://launchpad.net/python-distutils-extra >= 2.18"
-
-gettext.install('nova', unicode=1)
+from setuptools import setup
from nova import version