summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Kölker <jason@koelker.net>2013-02-18 17:26:26 -0600
committerJason Kölker <jason@koelker.net>2013-02-18 17:26:26 -0600
commit394876f258bf99132ba23c2e2bd07ee5ac6404cf (patch)
tree625ab0663003fa2d75ecfb93e35427bcd0f82c80 /setup.py
parent36bbf72d2f32a1ae10c484259cf7f29fbbfcd78e (diff)
downloadoslo-config-394876f258bf99132ba23c2e2bd07ee5ac6404cf.tar.gz
Make sure to install the oslo package as well.2013.1b4
Each package under a namespace that should install that namespace package so the __init__.py for the namespace gets copied. Fixes Bug 1129587 Change-Id: I064b05479c8a41d8f793886d2a5895dce166a85a
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ab4854d..02f9cae 100644
--- a/setup.py
+++ b/setup.py
@@ -42,7 +42,7 @@ setuptools.setup(
author_email='openstack-dev@lists.openstack.org',
url='http://www.openstack.org/',
license='Apache Software License',
- packages=['oslo.config'],
+ packages=['oslo', 'oslo.config'],
namespace_packages=['oslo'],
cmdclass=setup.get_cmdclass(),
install_requires=requires,