summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHervé Beraud <hberaud@redhat.com>2020-02-03 18:09:41 +0100
committerHervé Beraud <hberaud@redhat.com>2020-02-03 18:33:11 +0100
commitaba1098b7eb06fe185dc5d0f5aaaa33e2f70fa0b (patch)
tree002741bfb746b571a2836321fc3ad5dfa708ec1c /setup.py
parent82098f63bc51971ce87cb240a6ef0f146d3de3ed (diff)
downloadoslo-db-aba1098b7eb06fe185dc5d0f5aaaa33e2f70fa0b.tar.gz
[ussuri][goal] Drop python 2.7 support and testing7.0.0
OpenStack is dropping the py2.7 support in Ussuri cycle. Complete discussion & schedule can be found in - http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html - https://etherpad.openstack.org/p/drop-python2-support Ussuri Communtiy-wide goal: https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html Change-Id: I02e2d11d38d2aa4182e8d466519b99f05943701f
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 566d844..f63cc23 100644
--- a/setup.py
+++ b/setup.py
@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)