summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-29 13:46:40 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-29 13:46:40 +0000
commitfb889453b73be8ba2be9362e53234c42bb4330c0 (patch)
tree0a8c0a64e6a7e8d71e6d547a0a8f37078fa72081 /setup.py
parentae8e3ef410fdc32efa92d6ae5399a55353b5931a (diff)
downloadoslo-db-fb889453b73be8ba2be9362e53234c42bb4330c0.tar.gz
Updated from global requirements
Change-Id: I4716bc17dd898ecf25f730641fc6901ade0da7eb
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100755
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)