summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-09-24 09:02:12 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-09-24 09:02:12 +0000
commitb595944931d7d3b9d17d90a92578d5dacbc4906e (patch)
tree195c5f5c04ddd96ad7f01fb1f1dcd086b847da90 /setup.py
parentc7685a744a04f97e271d15a16bcbf7e33bc668f2 (diff)
downloadoslo-log-b595944931d7d3b9d17d90a92578d5dacbc4906e.tar.gz
Updated from global requirements
Change-Id: I51d9ba55b39663fe213ccd1446ff2c35b9e4bda4
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100755
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)