summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMark McLoughlin <markmc@redhat.com>2013-06-15 07:49:11 +0100
committerMark McLoughlin <markmc@redhat.com>2013-06-15 08:43:50 +0100
commitb5c41bba00375d4fb42e740c23b98a5b70af6820 (patch)
tree8e58a51da0a018e465fb0a28a9448dd6c008fe4f /setup.py
parent50f5f3b925aff18241ce2eed2f5018ca1b2368dc (diff)
downloadoslo-messaging-b5c41bba00375d4fb42e740c23b98a5b70af6820.tar.gz
Add oslo.messaging project infrastructure
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..59a0090
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+import setuptools
+
+setuptools.setup(
+ setup_requires=['d2to1', 'pbr'],
+ d2to1=True)