summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHervé Beraud <hberaud@redhat.com>2020-02-03 18:15:43 +0100
committerHervé Beraud <hberaud@redhat.com>2020-02-03 18:15:43 +0100
commit0f769d4c9f5f0833d4a2d999f494a1d36dd636ab (patch)
tree11238a4d2b535fbeb9ad3881d8845e5a7e282e23 /setup.py
parentc93f92b611c9186594df20a715c8ea88f6fb9f22 (diff)
downloadoslo-middleware-0f769d4c9f5f0833d4a2d999f494a1d36dd636ab.tar.gz
[ussuri][goal] Drop python 2.7 support and testing4.0.0
OpenStack is dropping the py2.7 support in Ussuri cycle. Complete discussion & schedule can be found in - http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html - https://etherpad.openstack.org/p/drop-python2-support Ussuri Communtiy-wide goal: https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html Change-Id: I8604e1a22d7cb13251e2ef22ef86318ad2de346e
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 566d844..f63cc23 100644
--- a/setup.py
+++ b/setup.py
@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)