summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRodrigo Duarte Sousa <rodrigods@lsd.ufcg.edu.br>2014-12-09 14:40:01 -0300
committerRodrigo Duarte Sousa <rodrigods@lsd.ufcg.edu.br>2014-12-09 14:40:01 -0300
commit520a60538b505e0167811d149a6b21888051c72e (patch)
treed06a10b2a9404bdc9e203e16b4eaf8660e327eca /setup.py
parent1d3efd6f63ac64d27d3b282d3bac9da6b05b7fd7 (diff)
downloadoslo-policy-520a60538b505e0167811d149a6b21888051c72e.tar.gz
exported from oslo-incubator by graduate.sh
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..7363757
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,30 @@
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr'],
+ pbr=True)