summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHervé Beraud <hberaud@redhat.com>2020-02-03 18:19:40 +0100
committerAndreas Jaeger <jaegerandi@gmail.com>2020-02-06 07:21:40 +0000
commit5fb2045c7a38efda9b3a85c995093da1ca26ef5d (patch)
treefd087ec5f5cac347f55fa13ce24a659d76227554 /setup.py
parente51d993fbca16d90505e1e1f09a773df0fdc9028 (diff)
downloadoslo-policy-5fb2045c7a38efda9b3a85c995093da1ca26ef5d.tar.gz
[ussuri][goal] Drop python 2.7 support and testing
OpenStack is dropping the py2.7 support in Ussuri cycle. Complete discussion & schedule can be found in - http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html - https://etherpad.openstack.org/p/drop-python2-support Ussuri Communtiy-wide goal: https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html Change-Id: If6a07eee86a2aaf65bdf9fbb338809ad47e02a46
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 566d844..f63cc23 100644
--- a/setup.py
+++ b/setup.py
@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)