summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-02-04 20:14:35 +0100
committerZane Bitter <zbitter@redhat.com>2020-02-10 16:05:51 +0000
commit2a8eb6a74c782ef76233179e9c32df5eb80d7233 (patch)
tree386a7c6cbd57f1ad15902b16c614ed7db4cd8f25 /setup.py
parent75ed1cedd9c3820134b877008750c4a28e28e2a0 (diff)
downloadpython-heatclient-2a8eb6a74c782ef76233179e9c32df5eb80d7233.tar.gz
[ussuri][goal] Drop python 2.7 support and testing2.0.0
OpenStack is dropping the py2.7 support in ussuri cycle. Complete discussion & schedule can be found in - http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html - https://etherpad.openstack.org/p/drop-python2-support Ussuri Communtiy-wide goal: https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html Change-Id: I54863f2301758dcd48de4ee73bcc8582e5036afa
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 566d844..f63cc23 100644
--- a/setup.py
+++ b/setup.py
@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)