summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSteve Baker <sbaker@redhat.com>2012-10-12 16:54:06 +1300
committerSteve Baker <sbaker@redhat.com>2012-10-12 16:54:06 +1300
commitb03183ce3fa1e7d0c505179e7cc7972b677ff36c (patch)
tree3315d455bb0ad81cb6f0dc3168877ec0d054b671 /setup.py
parent3c9c859e817695d3833c522ef4fcb386f70ebe60 (diff)
downloadpython-heatclient-b03183ce3fa1e7d0c505179e7cc7972b677ff36c.tar.gz
setup tweaks
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py42
1 files changed, 23 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index b0f9b5f..5091a11 100644
--- a/setup.py
+++ b/setup.py
@@ -1,33 +1,38 @@
-import os
-import sys
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+import os
import setuptools
from heatclient.openstack.common import setup
-requires = setup.parse_requirements()
-dependency_links = setup.parse_dependency_links()
-tests_require = setup.parse_requirements(['tools/test-requires'])
-
-if sys.version_info < (2, 6):
- requires.append('simplejson')
-
-
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
setuptools.setup(
name="python-heatclient",
version=setup.get_post_version('heatclient'),
+ author='Heat API Developers',
+ author_email='discuss@heat-api.org',
description="Client library for Heat orchestration API",
long_description=read('README.md'),
- url='https://github.com/heat-api/python-heatclient',
license='Apache',
- author='Heat API Developers',
- author_email='discuss@heat-api.org',
+ url='https://github.com/heat-api/python-heatclient',
packages=setuptools.find_packages(exclude=['tests', 'tests.*']),
include_package_data=True,
+ install_requires=setup.parse_requirements(),
+ test_suite="nose.collector",
+ cmdclass=setup.get_cmdclass(),
classifiers=[
'Development Status :: 4 - Beta',
'Environment :: Console',
@@ -37,11 +42,10 @@ setuptools.setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
],
- cmdclass=setup.get_cmdclass(),
- install_requires=requires,
- dependency_links=dependency_links,
- tests_require=tests_require,
+ entry_points={
+ 'console_scripts': ['heat = heatclient.shell:main']
+ },
+ dependency_links=setup.parse_dependency_links(),
+ tests_require=setup.parse_requirements(['tools/test-requires']),
setup_requires=['setuptools-git>=0.4'],
- test_suite="nose.collector",
- entry_points={'console_scripts': ['heat = heatclient.shell:main']},
)