summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSteve Baker <sbaker@redhat.com>2013-01-04 16:53:10 +1300
committerSteve Baker <sbaker@redhat.com>2013-01-09 11:23:12 +1300
commitbc972b214ee03d2b04ae9fe099e3ad59fd735b4b (patch)
tree437447425e979397eaf658274e6b36c95c46399d /setup.py
parent712e1726adcf30f48df3f855c14c2a5e80657dbe (diff)
downloadpython-heatclient-bc972b214ee03d2b04ae9fe099e3ad59fd735b4b.tar.gz
Switch to using version.canonical_version_string
Change-Id: Id095c61325b0d64bc77b742abf72958aeb4cde4d
Diffstat (limited to 'setup.py')
-rwxr-xr-x[-rw-r--r--]setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9c29f63..9de4201 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,5 @@
+#!/usr/bin/python
+#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
@@ -14,6 +16,7 @@ import os
import setuptools
from heatclient.openstack.common import setup
+from heatclient.version import version_info as version
def read(fname):
@@ -21,7 +24,7 @@ def read(fname):
setuptools.setup(
name="python-heatclient",
- version=setup.get_post_version('heatclient'),
+ version=version.canonical_version_string(always=True),
author='Heat API Developers',
author_email='discuss@heat-api.org',
description="Client library for Heat orchestration API",