summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-06-18 00:47:23 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-06-18 00:47:23 +0000
commite53e15e4806f089f804f3a094c8bd4146142a422 (patch)
tree7cdffa8441ac0e052a250e6d5bd002b7c0d050a1 /setup.py
parent93dcf9591dbd0966b2faca8fcc0a87203fbc83eb (diff)
downloadpython-heatclient-e53e15e4806f089f804f3a094c8bd4146142a422.tar.gz
Updated from global requirements
Change-Id: I4b438108b5e79a24d5e57e6c2a1a268f167123f8
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100755
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)