summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Geisler <martin@geisler.net>2014-05-28 11:02:12 +0200
committerMartin Geisler <martin@geisler.net>2014-05-31 13:22:44 +0200
commitaf741ec2236619880fa902d68aef4a6ae6cef534 (patch)
tree9780655c896d2e9a5e20353b15eaee509c5894d1 /setup.py
parent951f9a7ad2da1d8c5020318d621013ef96ffc5e6 (diff)
downloadpython-ironicclient-af741ec2236619880fa902d68aef4a6ae6cef534.tar.gz
Add UTF-8 coding lines to all Python files
While not strictly necessary for files containing only ASCII characters, adding a line with "coding: utf-8" can guard against future SyntaxError's in case someone inserts a Unicode literal. This commit adds such lines to all .py files. The syntax used by this commit works with Python (of course). It also works with Emacs, which will recognize the special "-*-" marker and use the "coding" variable to correctly decode the file, even in an environment where UTF-8 is not the default file encoding. Existing coding lines were normalized to match the new lines added. Partial-bug: #1325193 Change-Id: I58bf93fea711fd25890356a397e594bd820c99e3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7363757..4a00f9b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,6 @@
#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+#
# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");