summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-22 07:12:03 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-22 07:12:03 +0000
commit15bec1cde376a116b4a2308db58bbabc2b7f6d87 (patch)
tree34503b015583db9c9ab8fb1f15d266b1c40d9e0c /setup.py
parent2535f9e0e9e53041ff04ca734cb2bb4813cb8ad2 (diff)
downloadpython-keystoneclient-15bec1cde376a116b4a2308db58bbabc2b7f6d87.tar.gz
Updated from global requirements
Change-Id: I96f8f84be09b2e68e12d6c6b37079f83610c29a3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)