summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-03-21 10:34:46 -0400
committerMonty Taylor <mordred@inaugust.com>2012-03-21 10:48:51 -0400
commit6d67b4a6a24a9ed7eade711dd4f72bc3668dd6b4 (patch)
tree2665871ea63209034c8b49da644a47d52ca195c2 /setup.py
parent77742d7b134bd2066ea42982637a798c1d1cf068 (diff)
downloadpython-keystoneclient-6d67b4a6a24a9ed7eade711dd4f72bc3668dd6b4.tar.gz
Updated tox.ini to work properly with Jenkins.
As part of doing that, fixed a unittest to work with python2.6. Change-Id: I575a8534bf008077c1a24a25336f1d711f742297
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 14 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 1980746..ed6e7be 100644
--- a/setup.py
+++ b/setup.py
@@ -13,16 +13,16 @@ if sys.version_info < (2, 7):
requirements.append('argparse')
setup(
- name = "python-keystoneclient",
- version = "2012.1",
- description = "Client library for OpenStack Keystone API",
- long_description = read('README.rst'),
- url = 'https://github.com/openstack/python-keystoneclient',
- license = 'Apache',
- author = 'Nebula Inc, based on work by Rackspace and Jacob Kaplan-Moss',
- author_email = 'gabriel.hurley@nebula.com',
- packages = find_packages(exclude=['tests', 'tests.*']),
- classifiers = [
+ name="python-keystoneclient",
+ version="2012.1",
+ description="Client library for OpenStack Keystone API",
+ long_description=read('README.rst'),
+ url='https://github.com/openstack/python-keystoneclient',
+ license='Apache',
+ author='Nebula Inc, based on work by Rackspace and Jacob Kaplan-Moss',
+ author_email='gabriel.hurley@nebula.com',
+ packages=find_packages(exclude=['tests', 'tests.*']),
+ classifiers=[
'Development Status :: 4 - Beta',
'Environment :: Console',
'Intended Audience :: Developers',
@@ -31,12 +31,12 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
],
- install_requires = requirements,
+ install_requires=requirements,
- tests_require = ["nose", "mock", "mox"],
- test_suite = "nose.collector",
+ tests_require=["nose", "mock", "mox"],
+ test_suite="nose.collector",
- entry_points = {
+ entry_points={
'console_scripts': ['keystone = keystoneclient.shell:main']
}
)