summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-04-04 11:05:10 +0200
committerAndreas Jaeger <aj@suse.com>2020-04-04 14:15:46 +0200
commitb58ebe2b7f6166bd42469d1512bdcaf2fd216b4a (patch)
tree23c9463528f0226efbb5411448399cd6041bb152 /setup.py
parent4fcb68c6b9c42968be040b97417b44aec914c005 (diff)
downloadpython-keystoneclient-b58ebe2b7f6166bd42469d1512bdcaf2fd216b4a.tar.gz
Cleanup py27 supportussuri-em4.0.0
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete section from setup.cfg: Wheel is not needed for python 3 only repo - Update requirements, no need for python_version anymore - Remove future import from doc/source/conf.py Change-Id: Ibf594171cea8f81cc4139b29cbdce54f6d5107a7
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 566d844..cd35c3c 100644
--- a/setup.py
+++ b/setup.py
@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)