summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:46:46 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:46:46 +0000
commit0ca568242cb60ef86b7752ee2e2749f532027421 (patch)
tree7e9dcfade815e3cd8683604b9f64ea09e4f4f652 /setup.py
parent4c5f5458719bc475f46c22d4ad7f2997c58fcab8 (diff)
downloadpython-novaclient-0ca568242cb60ef86b7752ee2e2749f532027421.tar.gz
Updated from global requirements
Change-Id: I2f3f0b9f09e458eec4eb1e7a3b83e49043a8cb11
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f3..73637574 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)