summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJosh Kearney <josh@jk0.org>2011-11-16 15:21:25 -0600
committerJosh Kearney <josh@jk0.org>2011-11-17 10:17:49 -0600
commit149e00bcf5eeb16e4e5cc13840cdb6d0fe2897e3 (patch)
tree8d90475510cff9098230b398c601dd271b9a1340 /setup.py
parentd14e421ade04ecac86d0bd7bb56ded1c66f88ad9 (diff)
downloadpython-novaclient-149e00bcf5eeb16e4e5cc13840cdb6d0fe2897e3.tar.gz
Adds bash completion support and cleans up setup.py.
Also removes some unnecessary files and updates the AUTHORS file. Change-Id: Iefa502ce08cbf34038d2e04d0460ae43468a4255
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py74
1 files changed, 44 insertions, 30 deletions
diff --git a/setup.py b/setup.py
index c69b236f..09e15092 100644
--- a/setup.py
+++ b/setup.py
@@ -1,40 +1,54 @@
+# Copyright 2011 OpenStack, LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
import os
+import setuptools
import sys
-from setuptools import setup, find_packages
-
-def read(fname):
- return open(os.path.join(os.path.dirname(__file__), fname)).read()
-requirements = ['httplib2', 'argparse', 'prettytable']
+requirements = ["httplib2", "argparse", "prettytable"]
if sys.version_info < (2, 6):
- requirements.append('simplejson')
+ requirements.append("simplejson")
-setup(
- name = "python-novaclient",
- version = "2.6.7",
- description = "Client library for OpenStack Nova API",
- long_description = read('README.rst'),
- url = 'https://github.com/rackspace/python-novaclient',
- license = 'Apache',
- author = 'Rackspace, based on work by Jacob Kaplan-Moss',
- author_email = 'github@racklabs.com',
- packages = find_packages(exclude=['tests', 'tests.*']),
- classifiers = [
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'Intended Audience :: Information Technology',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- ],
- install_requires = requirements,
- tests_require = ["nose", "mock"],
- test_suite = "nose.collector",
+def read_file(file_name):
+ return open(os.path.join(os.path.dirname(__file__), file_name)).read()
- entry_points = {
- 'console_scripts': ['nova = novaclient.shell:main']
+
+setuptools.setup(
+ name="python-novaclient",
+ version="2.6.7",
+ author="Rackspace, based on work by Jacob Kaplan-Moss",
+ author_email="github@racklabs.com",
+ description="Client library for OpenStack Nova API.",
+ long_description=read_file("README.rst"),
+ license="Apache License, Version 2.0",
+ url="https://github.com/openstack/python-novaclient",
+ packages=["novaclient"],
+ install_requires=requirements,
+ tests_require=["nose", "mock"],
+ test_suite="nose.collector",
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Console",
+ "Intended Audience :: Developers",
+ "Intended Audience :: Information Technology",
+ "License :: OSI Approved :: Apache Software License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python"
+ ],
+ entry_points={
+ "console_scripts": ["nova = novaclient.shell:main"]
}
)