summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJulien Danjou <julien.danjou@enovance.com>2011-12-19 17:25:48 +0100
committerJulien Danjou <julien.danjou@enovance.com>2011-12-19 17:25:48 +0100
commit1e8c0bfa3f88362fc965e18cd5898a8578c5733f (patch)
tree12582f1fa69c3fc23c3be2a7a6defc42f2a52e2f /setup.py
parent3661be66730efd4bce32fd54e2443c42ad91edbd (diff)
downloadpython-novaclient-1e8c0bfa3f88362fc965e18cd5898a8578c5733f.tar.gz
Do no depends on argparse for Python >= 2.7
Python >= 2.7 has argparse has a builtin module, so there's no need to add it to the this list of requirements. Change-Id: I647cec70a564b1d184f0cb2aca6caf4d6478c403 Signed-off-by: Julien Danjou <julien.danjou@enovance.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c04d7b9f..c209667d 100644
--- a/setup.py
+++ b/setup.py
@@ -17,9 +17,11 @@ import setuptools
import sys
-requirements = ["httplib2", "argparse", "prettytable"]
+requirements = ["httplib2", "prettytable"]
if sys.version_info < (2, 6):
requirements.append("simplejson")
+if sys.version_info < (2, 7):
+ requirements.append("argparse")
def read_file(file_name):