summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorZiad Sawalha <github@highbridgellc.com>2011-11-17 05:12:46 -0600
committerZiad Sawalha <github@highbridgellc.com>2011-12-20 12:33:50 -0600
commit49284dc5cdbaeb70ebc5c56b9cdefbc40df9460d (patch)
tree1907b4be0a34184988d74b1f6402f4133a693e31 /setup.py
parente20dcd8cd74fd5076a0aa669b076df82f9056c57 (diff)
downloadpython-novaclient-49284dc5cdbaeb70ebc5c56b9cdefbc40df9460d.tar.gz
Add 'discover' command for Keystone discovery and version listing
Added @unauthenticated decorator to mark subcommands that do not need authentication. And checks to skip authentication for these commands. Added novaclient.keystone to setup.py Change-Id: Id2fd60af305c30a950bdbae8f897192bfae4d797
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c209667d..701295c3 100644
--- a/setup.py
+++ b/setup.py
@@ -37,7 +37,8 @@ setuptools.setup(
long_description=read_file("README.rst"),
license="Apache License, Version 2.0",
url="https://github.com/openstack/python-novaclient",
- packages=["novaclient", "novaclient.v1_1", "novaclient.v1_1.contrib"],
+ packages=["novaclient", "novaclient.v1_1", "novaclient.v1_1.contrib",
+ "novaclient.keystone"],
install_requires=requirements,
tests_require=["nose", "mock"],
test_suite="nose.collector",