summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobie Basak <robie.basak@canonical.com>2011-09-01 10:27:39 +0100
committerRobie Basak <robie.basak@canonical.com>2011-09-01 16:55:26 +0100
commitc31aeb19be1b0a09ace8b03727385041d610188f (patch)
tree5537b71753fb202bfa52bc2e08a873eef5206b0b /setup.py
parent597ef2f5b6bd51da02cc4c83c6295a5e3cb3f3c9 (diff)
downloadpython-novaclient-c31aeb19be1b0a09ace8b03727385041d610188f.tar.gz
Fix test installation exclude
With exclude=['tests'], tests.v1_0 and tests.v1_1 do not get excluded, causing "python setup.py install" to pollute dist-packages with "tests" rather than going under novaclient/ exclude=['tests', 'tests.*'] fixes this. LP: #838298 Also see LP: #825127 comment #3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0dc6caf3..c3a4e494 100644
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,7 @@ setup(
license = 'Apache',
author = 'Rackspace, based on work by Jacob Kaplan-Moss',
author_email = 'github@racklabs.com',
- packages = find_packages(exclude=['tests']),
+ packages = find_packages(exclude=['tests', 'tests.*']),
classifiers = [
'Development Status :: 5 - Production/Stable',
'Environment :: Console',