summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBrian Waldon <brian.waldon@rackspace.com>2011-07-29 10:06:05 -0400
committerBrian Waldon <brian.waldon@rackspace.com>2011-07-29 10:06:05 -0400
commitca8aa158fc0d1ab9f653f79f4bb5169a7884b0b6 (patch)
tree03a77d762a518d91bcd584e083991bda4ae3ca49 /setup.py
parent20251ccc2ff7a8d030647c92c9a5a288ed5c1229 (diff)
downloadpython-novaclient-ca8aa158fc0d1ab9f653f79f4bb5169a7884b0b6.tar.gz
updating server backup action; pep8 fixes
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py35
1 files changed, 18 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 6adef8c3..4e66ec2b 100644
--- a/setup.py
+++ b/setup.py
@@ -2,24 +2,25 @@ import os
import sys
from setuptools import setup, find_packages
+
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
requirements = ['httplib2', 'argparse', 'prettytable']
-if sys.version_info < (2,6):
+if sys.version_info < (2, 6):
requirements.append('simplejson')
setup(
- name = "python-novaclient",
- version = "2.5.8",
- description = "Client library for OpenStack Nova API",
- long_description = read('README.rst'),
- url = 'https://github.com/rackspace/python-novaclient',
- license = 'Apache',
- author = 'Rackspace, based on work by Jacob Kaplan-Moss',
- author_email = 'github@racklabs.com',
- packages = find_packages(exclude=['tests']),
- classifiers = [
+ name="python-novaclient",
+ version="2.5.8",
+ description="Client library for OpenStack Nova API",
+ long_description=read('README.rst'),
+ url='https://github.com/rackspace/python-novaclient',
+ license='Apache',
+ author='Rackspace, based on work by Jacob Kaplan-Moss',
+ author_email='github@racklabs.com',
+ packages=find_packages(exclude=['tests']),
+ classifiers=[
'Development Status :: 5 - Production/Stable',
'Environment :: Console',
'Intended Audience :: Developers',
@@ -28,12 +29,12 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
],
- install_requires = requirements,
-
- tests_require = ["nose", "mock"],
- test_suite = "nose.collector",
-
- entry_points = {
+ install_requires=requirements,
+
+ tests_require=["nose", "mock"],
+ test_suite="nose.collector",
+
+ entry_points={
'console_scripts': ['nova = novaclient.shell:main']
}
)