summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRoman Podolyaka <rpodolyaka@mirantis.com>2013-05-18 11:53:18 +0300
committerRoman Podolyaka <rpodolyaka@mirantis.com>2013-05-19 10:00:38 +0300
commitf08ac04a27fe6bc2969252bcc4578d12f242f1f4 (patch)
tree1412694d1519ef03b086a04f6c370bc7ecedbde2 /setup.py
parent64e43fde43e478af8dc95ccc0904dfca0d0dbe0c (diff)
downloadpython-novaclient-f08ac04a27fe6bc2969252bcc4578d12f242f1f4.tar.gz
Migrate to pbr.
openstack.common.setup and openstack.common.version are now in the standalone library pbr, so all projects using those two should migrate. Fixes bug 1179007. Change-Id: I7ac1c37f0bf148619dffff8f454db05fc192e471
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 4 insertions, 32 deletions
diff --git a/setup.py b/setup.py
index d896f34e..726cd9c6 100644
--- a/setup.py
+++ b/setup.py
@@ -12,41 +12,13 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-import os
import setuptools
-from novaclient.openstack.common import setup
-
-
-def read_file(file_name):
- return open(os.path.join(os.path.dirname(__file__), file_name)).read()
-project = 'python-novaclient'
setuptools.setup(
- name=project,
- version=setup.get_version(project),
- author='OpenStack',
- author_email='openstack-dev@lists.openstack.org',
- description="Client library for OpenStack Compute API.",
- long_description=read_file("README.rst"),
- license="Apache License, Version 2.0",
- url="https://github.com/openstack/python-novaclient",
- packages=setuptools.find_packages(exclude=['tests', 'tests.*']),
- install_requires=setup.parse_requirements(),
- cmdclass=setup.get_cmdclass(),
- setup_requires=['setuptools_git>=0.4'],
- include_package_data=True,
- classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Environment :: Console",
- "Environment :: OpenStack",
- "Intended Audience :: Developers",
- "Intended Audience :: Information Technology",
- "License :: OSI Approved :: Apache Software License",
- "Operating System :: OS Independent",
- "Programming Language :: Python"
+ setup_requires=[
+ 'd2to1>=0.2.10,<0.3',
+ 'pbr>=0.5,<0.6'
],
- entry_points={
- "console_scripts": ["nova = novaclient.shell:main"]
- },
+ d2to1=True
)