summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPeng Yong <ppyy@pubyun.com>2012-04-01 18:33:56 +0800
committerPeng Yong <ppyy@pubyun.com>2012-04-03 00:00:48 +0800
commitf3709bc6b6288752aaee93ea051278841d7039de (patch)
tree3339d32458b6ff1f27d1f63c65f51534aece8a6b /setup.py
parent2db73cd5a1facb888d9c1cfb75d350b8b53f9a0e (diff)
downloadpython-novaclient-f3709bc6b6288752aaee93ea051278841d7039de.tar.gz
add packages using find_packages()
Change-Id: Ib745254276b67cc09f6a9e8d3ac8f5aea7741903
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 45734092..264cbbaf 100644
--- a/setup.py
+++ b/setup.py
@@ -37,7 +37,7 @@ setuptools.setup(
long_description=read_file("README.rst"),
license="Apache License, Version 2.0",
url="https://github.com/openstack/python-novaclient",
- packages=["novaclient", "novaclient.v1_1", "novaclient.v1_1.contrib"],
+ packages=setuptools.find_packages(exclude=['tests', 'tests.*']),
install_requires=requirements,
tests_require=["nose", "mock"],
test_suite="nose.collector",