summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-04-04 17:11:37 +0200
committerLuigi Toscano <ltoscano@redhat.com>2020-04-07 14:51:08 +0200
commit830d4607c3f20910c5a044ab5aa4d91e6bdb042a (patch)
tree68830e1248f2364a11510f73205e47f383692103 /setup.cfg
parentcca4f4d0c8a33a776e17413f5fda94c088b6a233 (diff)
downloadpython-saharaclient-830d4607c3f20910c5a044ab5aa4d91e6bdb042a.tar.gz
Cleanup py27 supportussuri-em3.1.0
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete sections from setup.cfg: * Wheel is not needed for python 3 only repo * Some other sections are obsolete - Update classifiers - Update requirements, no need for python_version anymore Change-Id: I95a49a2941790e0df1fde38f253ba2516959ce80
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg9
1 files changed, 3 insertions, 6 deletions
diff --git a/setup.cfg b/setup.cfg
index 704b62c..b8fc9b6 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -7,6 +7,7 @@ license = Apache License, Version 2.0
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/python-saharaclient/latest/
+python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@@ -14,13 +15,12 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
-[global]
-setup-hooks = pbr.hooks.setup_hook
-
[files]
packages =
saharaclient
@@ -161,6 +161,3 @@ openstack.data_processing.v2 =
dataprocessing_job_binary_update = saharaclient.osc.v2.job_binaries:UpdateJobBinary
dataprocessing_job_binary_delete = saharaclient.osc.v2.job_binaries:DeleteJobBinary
dataprocessing_job_binary_download = saharaclient.osc.v2.job_binaries:DownloadJobBinary
-
-[wheel]
-universal = 1