summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCheng Li <shcli@cn.ibm.com>2016-06-27 16:04:13 +0800
committerTim Burke <tim@swiftstack.com>2016-07-06 02:16:52 +0000
commit13494098e2941ff87d80710ecc00c35142851175 (patch)
treec5d3a442e90d79bec8cac8e78394196753d6c920 /setup.py
parent07c960d46fe8412d98799b1820d57810a9a8a3e7 (diff)
downloadpython-swiftclient-13494098e2941ff87d80710ecc00c35142851175.tar.gz
Add python version constraint python>=2.7
The 'swift' command from v3.0.0 does not work in Python 2.6, bacause some code is incompatible with Python 2.6 This patch is to add a constraint of python version Change-Id: I5197cba0c2cd3135d08498df827a52f8bba98d4d Closes-bug: #1590334
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..16a18f6 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,11 @@
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
-import setuptools
+import setuptools, sys
+
+if sys.version_info < (2, 7):
+ sys.exit('Sorry, Python < 2.7 is not supported for'
+ ' python-swiftclient>=3.0')
setuptools.setup(
setup_requires=['pbr'],