summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-05-16 17:30:46 -0400
committerMonty Taylor <mordred@inaugust.com>2012-05-16 17:30:46 -0400
commit7df012329f0b22e19f878cee2602407cb23042ef (patch)
tree3a41d7654defd31b62519a868a27b7e589d02a02 /setup.py
parenta42892c1f99595f2aafb2c32bb2b4697a7d600de (diff)
downloadpython-swiftclient-7df012329f0b22e19f878cee2602407cb23042ef.tar.gz
Add openstack project infrastructure.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py31
1 files changed, 25 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 926e142..6b2818f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,32 +1,51 @@
+#!/usr/bin/python
# -*- encoding: utf-8 -*-
+# Copyright (c) 2010 OpenStack, LLC.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
import os
import setuptools
import sys
-# TODO: Figuring out how we are going to do the versionning (and if
+from swiftclient.openstack.common import setup
+
+# TODO: Figuring out how we are going to do the versioning (and if
# any).
version = '1.0'
name = 'python-swiftclient'
-requires = []
+
+requires = setup.parse_requirements()
+depend_links = setup.parse_dependency_links()
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
-if sys.version_info < (2, 6):
- requires.append('simplejson')
-
setuptools.setup(
name=name,
version=version,
description='Client Library for OpenStack Object Storage API',
long_description=read('README.rst'),
- url='https://github.com/chmouel/python-swiftclient',
+ url='https://github.com/openstack/python-swiftclient',
license='Apache License (2.0)',
author='OpenStack, LLC.',
author_email='openstack-admins@lists.launchpad.net',
packages=setuptools.find_packages(exclude=['tests', 'tests.*']),
+ cmdclass=setup.get_cmdclass(),
install_requires=requires,
+ dependency_links=depend_links,
classifiers=[
'Development Status :: 4 - Beta',
'Environment :: Console',