summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTim Burke <tim.burke@gmail.com>2018-05-16 17:33:40 +0000
committerTim Burke <tim.burke@gmail.com>2018-07-11 13:09:00 -0700
commitda362a653e9c70cb6ae17a7c3764887b4fd3fcf2 (patch)
treed705e880aff1078d8b1cb7228e629f9003bf655c /setup.py
parentc2c5af603f8ae25be052a20b02dc109b0f8f014a (diff)
downloadpython-swiftclient-da362a653e9c70cb6ae17a7c3764887b4fd3fcf2.tar.gz
Back out some version bumps
I'm giving up on trying to back out all of the test-requirements up-revs, but let's try to stay compatibile with old requests/six. As part of that, only disable some requests warnings on new-enough requests. Note that we should now be compatible with distro packages back to Ubuntu 16.04 and CentOS 6. Our six is still too new for Trusty, but hey, there's less than a year left on that anyway, right? Change-Id: Iccb23638393616f9ec3da660dd5e39ea4ea94220 Related-Change: I2a8f465c8b08370517cbec857933b08fca94ca38
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 4 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 518f1d3..16a18f6 100644
--- a/setup.py
+++ b/setup.py
@@ -17,16 +17,10 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools, sys
-import setuptools
-
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
+if sys.version_info < (2, 7):
+ sys.exit('Sorry, Python < 2.7 is not supported for'
+ ' python-swiftclient>=3.0')
setuptools.setup(
- setup_requires=['pbr>=2.0.0'],
+ setup_requires=['pbr'],
pbr=True)