summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChmouel Boudjnah <chmouel@chmouel.com>2013-11-21 17:59:47 +0100
committerJohn Dickinson <me@not.mn>2013-11-21 14:09:47 -0800
commit64b976e139ecfeafa83889a9c6d6615d30ba5635 (patch)
tree004b28b0adc658847d4a76860ee81de266adc6eb /setup.py
parent3ac1ff77535e3d23ef92921e15058b35ff13e5f9 (diff)
downloadswift-bench-64b976e139ecfeafa83889a9c6d6615d30ba5635.tar.gz
Add plumbing.
- Update .gitignore to ignore all testrunners. - Move swift-bench to swiftbench. - Move tests to tests/ - Add some simple {test-,}requirements (more works needs to be done to get proper versioning) Change-Id: Iab4d65f02cbce8c99ecafa30d15c4cb11f0b4293
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py53
1 files changed, 53 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..345ea38
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,53 @@
+#!/usr/bin/python
+# Copyright (c) 2010-2012 OpenStack, LLC.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from setuptools import setup, find_packages
+
+from swiftbench import __version__ as version
+
+
+name = 'swift-bench'
+
+with open('requirements.txt', 'r') as f:
+ requires = [x.strip() for x in f if x.strip()]
+
+
+setup(
+ name=name,
+ version=version,
+ description='Benchmark tool for OpenStack Swift',
+ license='Apache License (2.0)',
+ author='OpenStack',
+ author_email='openstack-dev@lists.openstack.org',
+ url='http://openstack.org',
+ packages=find_packages(exclude=['test', 'bin']),
+ test_suite='nose.collector',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Environment :: No Input/Output (Daemon)',
+ 'Environment :: OpenStack',
+ ],
+ install_requires=requires,
+ scripts=[
+ 'bin/swift-bench',
+ 'bin/swift-bench-client',
+ ],
+)