summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Barton <mike@weirdlooking.com>2013-01-31 21:53:47 -0800
committerMichael Barton <mike@weirdlooking.com>2013-02-05 06:03:38 -0800
commit24ef12027c7b6e1e2f55275bed18ceac725e27a5 (patch)
tree38151ff573573c4e23c0436ed9121ef410c04991 /setup.py
parent65baec39d221b05c61eb58e635157db754b9f869 (diff)
downloadswift-24ef12027c7b6e1e2f55275bed18ceac725e27a5.tar.gz
Basic container quotas
Add a new middleware implementing some basic container quotas. Quotas are subject to several limitations: eventual consistency, the timeliness of the cached container_info (60 second ttl by default), and it’s unable to reject chunked transfer uploads that exceed the quota (though once the quota is exceeded, new chunked transfers will be refused). However, they get most of the way to container quotas fairly inexpensively. Quotas are set by adding meta values to the container, and are validated when set: X-Container-Meta-Quota-Bytes: Maximum size of the container, in bytes. X-Container-Meta-Quota-Count: Maximum object count of the container. DocImpact Change-Id: I77cfbf6dc231a2e522bd67328e4c082424a93eee
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 35ddb0e08..9914ea7b8 100644
--- a/setup.py
+++ b/setup.py
@@ -99,9 +99,11 @@ setup(
'tempurl=swift.common.middleware.tempurl:filter_factory',
'formpost=swift.common.middleware.formpost:filter_factory',
'name_check=swift.common.middleware.name_check:filter_factory',
- 'proxy_logging='
- 'swift.common.middleware.proxy_logging:filter_factory',
'bulk=swift.common.middleware.bulk:filter_factory',
+ 'container_quotas=swift.common.middleware.container_quotas:'
+ 'filter_factory',
+ 'proxy_logging=swift.common.middleware.proxy_logging:'
+ 'filter_factory',
],
},
)