summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSoren Hansen <soren@linux2go.dk>2011-05-26 11:25:39 +0200
committerSoren Hansen <soren@linux2go.dk>2011-05-26 11:25:39 +0200
commit2d1274c4974c7231a00cd835aedb31b7a349e710 (patch)
treeb2664dd08c51f232b5db8608277035b17aa5691f /setup.py
parente3b6de6c08fe2d57e8ba227b7e4f357f2db1d8a1 (diff)
downloadswift-2d1274c4974c7231a00cd835aedb31b7a349e710.tar.gz
Add a __canonical_version__ attribute to the swift module. This is only the numbered part of the version string, no "-dev" or similar suffixes.
Add a couple of unit tests to make sure __version__ and __canonical_version__ are generated correctly and to ensure __canonical_version__ never accidentally has anything other than numbers and points in it.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ec656122e..913c3dbfe 100644
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,7 @@ try:
except ImportError:
frontend = None
-from swift import __version__ as version
+from swift import __canonical_version__ as version
class local_sdist(sdist):