summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorClay Gerrard <clay.gerrard@gmail.com>2013-03-25 16:34:43 -0700
committerClay Gerrard <clay.gerrard@gmail.com>2013-04-30 00:17:46 -0700
commit34f5085c3e143a27d9f3c4980b5b04514d78e659 (patch)
treeabe00d9cad81bdc061545c4e96e44cebb7ade7b3 /setup.py
parent52a6595033732b9d9cc1258049f3bddb15f3b505 (diff)
downloadswift-34f5085c3e143a27d9f3c4980b5b04514d78e659.tar.gz
conf.d support
Allow Swift daemons and servers to optionally accept a directory as the configuration parameter. Directory based configuration leverages ConfigParser's native multi-file support. Files ending in '.conf' in the given directory are parsed in lexicographical order. Filenames starting with '.' are ignored. A mixture of file and directory configuration paths is not supported - if the configuration path is a file behavior is unchanged. * update swift-init to search for conf.d paths when building servers (e.g. /etc/swift/proxy-server.conf.d/) * new script swift-config can be used to inspect the cumulative configuration * pull a little bit of code out of run_wsgi and test separately * fix example config bug for the proxy servers client_disconnect option * added section on directory based configuration to deployment guide DocImpact Implements: blueprint confd Change-Id: I89b0f48e538117f28590cf6698401f74ef58003b
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 229dc97e1..29f486542 100644
--- a/setup.py
+++ b/setup.py
@@ -55,6 +55,7 @@ setup(
'bin/swift-account-server',
'bin/swift-bench',
'bin/swift-bench-client',
+ 'bin/swift-config',
'bin/swift-container-auditor',
'bin/swift-container-replicator',
'bin/swift-container-server',