summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Dickinson <me@not.mn>2014-05-21 09:37:22 -0700
committerJohn Dickinson <me@not.mn>2014-05-21 09:37:22 -0700
commit85c03d8b1d44829f26965208ef02b6f8aa02d143 (patch)
treea3273df0d0bbc5239c2d0a3bdf699b45ebf22c45 /setup.py
parentdab96bec6dd3275e26837fa19116f2924558df4c (diff)
downloadswift-85c03d8b1d44829f26965208ef02b6f8aa02d143.tar.gz
taking the global reqs that we can
Change-Id: Icfdeeab14e90728aa8167ad6587d51e9b10cb846
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f32..736375744 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)