summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEamonn O'Toole <eamonn.otoole@hp.com>2012-03-02 11:23:17 +0000
committerEamonn O'Toole <eamonn.otoole@hp.com>2012-03-08 17:23:58 +0000
commitcf1aa3c309a6fcb57755da6732226b494f0bf69b (patch)
tree5e26709e49e88cfb5bc99218303933db470e4e6b /setup.py
parent097cca1451c9ffec965a36c9c62a8f06bfb6a904 (diff)
downloadswift-cf1aa3c309a6fcb57755da6732226b494f0bf69b.tar.gz
Adds name_check filter
Bug 926048. Filter checks path for user-defined forbidden characters, and for user-defined maximum length. Includes changes to reflect gholt's latest comments to Patch Set 4 Also includes a change to a unit-test, renames another unit-test, and removes one superfluous unit-test. Added section to the example proxy config Fixed-up unit test pep8 warnings Changed error response code to 400 (Bad Request) Change-Id: Iace719d6a3d00fb3dda1b9d0bc185b8c4cbc00ca
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 8f0e2321f..06131565a 100644
--- a/setup.py
+++ b/setup.py
@@ -93,6 +93,7 @@ setup(
'recon=swift.common.middleware.recon:filter_factory',
'tempurl=swift.common.middleware.tempurl:filter_factory',
'formpost=swift.common.middleware.formpost:filter_factory',
+ 'name_check=swift.common.middleware.name_check:filter_factory',
],
},
)