summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDarrell Bishop <darrell@swiftstack.com>2012-08-25 23:02:53 -0700
committerGerrit Code Review <review@openstack.org>2012-08-30 18:22:49 +0000
commited3b12d05caa8d807e8fea1036b8d21013bcab80 (patch)
treea518da733e59ad6e5169f0ebfb39c0e4e654270f /setup.py
parentc509ac23711edb70caf62697592e11f56e8d7b95 (diff)
downloadswift-ed3b12d05caa8d807e8fea1036b8d21013bcab80.tar.gz
Can run swift-bench across multiple cores/servers.
You run one or more swift-bench-client processes like this: $ swift-bench-client 127.0.0.1 20001 $ swift-bench-client 127.0.0.1 20002 Then you run swift-bench with a new option, --bench-clients (-b), which is specified once for each swift-bench-client: $ swift-bench -b 127.0.0.1:20001 -b 127.0.0.1:20002 You get log lines from each client (interleaved) along with a final report for all clients: 127.0.0.1:20002 swift-bench-server 2012-08-25 22:44:06,148 INFO Auth version: 1.0 127.0.0.1:20001 swift-bench-server 2012-08-25 22:44:06,148 INFO Auth version: 1.0 127.0.0.1:20001 swift-bench-server 2012-08-25 22:44:12,249 INFO 83 PUTS [0 failures], 41.5/s 127.0.0.1:20002 swift-bench-server 2012-08-25 22:44:14,430 INFO 74 PUTS [0 failures], 34.3/s ... 127.0.0.1:20002 swift-bench-server 2012-08-25 22:45:18,942 INFO Auth version: 1.0 127.0.0.1:20002 swift-bench-server 2012-08-25 22:45:20,946 INFO 238 DEL [2 failures], 118.9/s swift-bench 2012-08-25 22:45:27,549 INFO 2000 PUTS **FINAL** [0 failures], 56.8/s swift-bench 2012-08-25 22:45:27,550 INFO 30000 GETS **FINAL** [50 failures], 974.6/s swift-bench 2012-08-25 22:45:27,550 INFO 2000 DEL **FINAL** [20 failures], 237.1/s The concurrency, PUT count, and GET count config settings are divided by the number of bench_clients. In other words, the same volume of work is attempted (vs. not specifying --bench-clients), but it can now span servers and CPU cores. Benchmark containers are created (if use_proxy = yes) and deleted (if delete = yes), with appropriate concurrency, in the initiating swift-bench process, not any of the swift-bench-client processes. Change-Id: Idbf31a23093244ab357a9bf77e6031257774f24a
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 185d11fee..edb0ce4b9 100644
--- a/setup.py
+++ b/setup.py
@@ -47,6 +47,7 @@ setup(
'bin/swift-account-replicator',
'bin/swift-account-server',
'bin/swift-bench',
+ 'bin/swift-bench-client',
'bin/swift-container-auditor',
'bin/swift-container-replicator',
'bin/swift-container-server',