summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-01 13:51:51 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-01 13:51:51 +0000
commit0a811cd48dad78a9477c52620ff071db0758af6a (patch)
tree67c62a87de9fd2c98bcf852f50a345bb1ea18d34 /setup.py
parent381c164f043793224cf3c7c4a0f7c8b2c2a809f4 (diff)
downloadtrove-0a811cd48dad78a9477c52620ff071db0758af6a.tar.gz
Updated from global requirements
Change-Id: Iab7b6ed1890b7da98f4916dc90b523b52674f59c
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f3..73637574 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)