summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlavio Leitner <fbl@redhat.com>2017-06-26 21:55:50 -0300
committerBen Pfaff <blp@ovn.org>2017-07-13 10:57:14 -0700
commit0eaaacac9488fd1746ba639314a502016059941e (patch)
tree399b440973bbf65f191ec3fb290cdfd238637993 /Makefile.am
parente4713f24d5ee521e434acf53a9f36d3658c11a64 (diff)
downloadopenvswitch-0eaaacac9488fd1746ba639314a502016059941e.tar.gz
ctags: include symbols with locking annotations.
OVS uses extensively clang annotations for thread safety checks. The ctags tool can't parse them, so they are not included in the tag file. This patch improves the configure script to generate a list of identifiers from the header compiler.h to be ignored by ctags. Signed-off-by: Flavio Leitner <fbl@redhat.com> Signed-off-by: Ben Pfaff <blp@ovn.org> Reviewed-by: Aaron Conole <aconole@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e11e04ac..9679379de 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,6 +42,8 @@ AM_CPPFLAGS += -DNDEBUG
AM_CFLAGS += -fomit-frame-pointer
endif
+AM_CTAGSFLAGS = $(OVS_CTAGS_IDENTIFIERS_LIST)
+
if WIN32
psep=";"
else