summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlin Serdean <aserdean@cloudbasesolutions.com>2015-09-23 17:30:32 +0000
committerGurucharan Shetty <gshetty@nicira.com>2015-09-29 11:17:42 -0700
commit1cb3649c0bbacf4f3cea353d02a5e1217b5294b4 (patch)
tree47ea041e4038d65bfa1d5c14984b2118037988f3 /Makefile.am
parent34e1211b9a05d42a77cfac185361fc0539f77b21 (diff)
downloadopenvswitch-1cb3649c0bbacf4f3cea353d02a5e1217b5294b4.tar.gz
Add build system for compiling under MSVC x64
This patch adds the modifications needed to compile under x64 under Windows: - created a new macro for testing if we are compiling under x64. this will define the linker flag: "/MACHINE:X64" as per documentation (https://msdn.microsoft.com/en-us/library/9yb4317s.aspx). - added x64 pthread libraries under the pthread defines - add documentation on how to build under x64 Signed-off-by: Alin Gabriel Serdean <aserdean@cloudbasesolutions.com> Signed-off-by: Gurucharan Shetty <gshetty@nicira.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a659814cf..ab1a1356f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@ AM_CPPFLAGS += -I $(top_srcdir)/datapath-windows/include
AM_CPPFLAGS += $(PTHREAD_INCLUDES)
AM_CPPFLAGS += $(MSVC_CFLAGS)
AM_LDFLAGS += $(PTHREAD_LDFLAGS)
+AM_LDFLAGS += $(MSVC64_LDFLAGS)
endif
AM_CPPFLAGS += -I $(top_srcdir)/include