summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimothy Redaelli <tredaelli@redhat.com>2020-09-03 16:55:43 +0200
committerIlya Maximets <i.maximets@ovn.org>2020-09-16 00:18:13 +0200
commit32ae689274032eecc38d569d47576f191d746c5d (patch)
tree76b9fddf7b88e0f1f34c427e3702a02a36defbad /Makefile.am
parent7024ddf3202646095adfbb1998904abd7b21f6e3 (diff)
downloadopenvswitch-32ae689274032eecc38d569d47576f191d746c5d.tar.gz
Remove manpages.mk from git.
manpages.mk is generated at build-time using sodepends.py and so there is no need to keep it in git. Signed-off-by: Timothy Redaelli <tredaelli@redhat.com> Acked-by: Flavio Leitner <fbl@sysclose.org> Signed-off-by: Ilya Maximets <i.maximets@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 27ef9e4b4..6981b943e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -412,8 +412,8 @@ flake8-check: $(FLAKE8_PYFILES)
endif
CLEANFILES += flake8-check
-include $(srcdir)/manpages.mk
-$(srcdir)/manpages.mk: $(MAN_ROOTS) build-aux/sodepends.py python/build/soutil.py
+-include manpages.mk
+manpages.mk: $(MAN_ROOTS) build-aux/sodepends.py python/build/soutil.py
@PYTHONPATH=$$PYTHONPATH$(psep)$(srcdir)/python $(PYTHON3) $(srcdir)/build-aux/sodepends.py -I. -I$(srcdir) $(MAN_ROOTS) >$(@F).tmp
@if cmp -s $(@F).tmp $@; then \
touch $@; \
@@ -421,6 +421,7 @@ $(srcdir)/manpages.mk: $(MAN_ROOTS) build-aux/sodepends.py python/build/soutil.p
else \
mv $(@F).tmp $@; \
fi
+CLEANFILES += manpages.mk
CLEANFILES += manpage-dep-check
if VSTUDIO_DDK