summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2017-03-07 20:48:08 -0800
committerBen Pfaff <blp@ovn.org>2017-03-08 10:21:29 -0800
commit344f62538637c0cccb0de0c800db222b5a4ab3c2 (patch)
treea0fd942b941f775c2c48a5b46b684b7ebbebff2c /Makefile.am
parentdb8dcbaf1c57efb1fbd29cee598a6a84a2a5f9ec (diff)
downloadopenvswitch-344f62538637c0cccb0de0c800db222b5a4ab3c2.tar.gz
Makefile: Drop vestiges of support for non-GNU Make.
Open vSwitch has documented a requirement for GNU Make for a long time, yet it had vestiges catering to other make implementations. This removes those. Signed-off-by: Ben Pfaff <blp@ovn.org> Acked-by: Russell Bryant <russell@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 90f5c0353..c853085b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -184,11 +184,6 @@ CLEAN_LOCAL += clean-pycov
# If we're checked out from a Git repository, make sure that every
# file that is in Git is distributed.
-#
-# We only enable this check when GNU make is in use because the
-# Makefile in datapath/linux, needed to get the list of files to
-# distribute, requires GNU make extensions.
-if GNU_MAKE
ALL_LOCAL += dist-hook-git
dist-hook-git: distfiles
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \
@@ -220,7 +215,6 @@ distfiles: Makefile
-e "s|^$$topsrcdirstrip/|$(top_builddir)/|;t" | \
LC_ALL=C sort -u > $@
CLEANFILES += distfiles
-endif
.PHONY: dist-hook-git
# Check that every .c file includes <config.h>.