summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlin Gabriel Serdean <aserdean@ovn.org>2018-07-19 19:39:42 +0300
committerAlin Gabriel Serdean <aserdean@ovn.org>2018-07-19 21:02:33 +0300
commit3c921cc2b6b760bd0db73fd629ee9614edc8914c (patch)
treeaec3c0a2f9d3d4b3573a958bd5a301031a5331dd /Makefile.am
parent7c1ccbd1fbde4cf3498ea4f159e687637539d64b (diff)
downloadopenvswitch-3c921cc2b6b760bd0db73fd629ee9614edc8914c.tar.gz
build: Add gitattribute file to build-aux
The command: `make check-tabs` fails on Windows due to line ending conversions caused by the following setting: `git config --global core.autocrlf true` (the whitelist `build-aux/initial-tab-whitelist` becomes a blacklist) This patch adds a .gittatribute file to build-aux to force LF endings on Windows. Signed-off-by: Alin Gabriel Serdean <aserdean@ovn.org> Co-authored-by: Aaron Conole <aconole@redhat.com> Signed-off-by: Aaron Conole <aconole@redhat.com> Acked-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e02799a90..fd6620a9b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -199,6 +199,7 @@ dist-hook-git: distfiles
(cat distfiles; sed 's|^|datapath/|' datapath/distfiles) | \
LC_ALL=C sort -u > all-distfiles; \
(cd $(srcdir) && git ls-files) | grep -v '\.gitignore$$' | \
+ grep -v '\.gitattributes$$' | \
LC_ALL=C sort -u > all-gitfiles; \
LC_ALL=C comm -1 -3 all-distfiles all-gitfiles > missing-distfiles; \
if test -s missing-distfiles; then \