summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGreg Rose <gvrose8192@gmail.com>2022-07-14 14:23:29 -0700
committerIlya Maximets <i.maximets@ovn.org>2022-07-15 13:45:55 +0200
commit422e90437854c441a0b274d3bf06ce7d6bbf9de0 (patch)
tree0e65141df83a618e59b00eb96e9c806bfbd51a39 /Makefile.am
parent86642de3ad8d42ab2b5dbace241d8dc398bd1195 (diff)
downloadopenvswitch-422e90437854c441a0b274d3bf06ce7d6bbf9de0.tar.gz
make: Remove the Linux datapath.
Update the necessary make and configure files to remove the Linux datapath and then remove the datapath. Move datapath/linux/compat/include/linux/openvswitch.h to include/linux/openvswitch.h because it is needed to generate header files used by the userspace switch. Also remove references to the Linux datapath from auxiliary files and utilities since it is no longer supported. Signed-off-by: Greg Rose <gvrose8192@gmail.com> Reviewed-by: David Marchand <david.marchand@redhat.com> Signed-off-by: Ilya Maximets <i.maximets@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 7 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index cb8076433..fff98564a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,6 @@
AUTOMAKE_OPTIONS = foreign subdir-objects
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = datapath
AM_CPPFLAGS = $(SSL_CFLAGS)
AM_LDFLAGS = $(SSL_LDFLAGS)
@@ -198,25 +197,22 @@ CLEAN_LOCAL += clean-pycov
ALL_LOCAL += dist-hook-git
dist-hook-git: distfiles
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \
- (cd datapath && $(MAKE) distfiles); \
- (cat distfiles; sed 's|^|datapath/|' datapath/distfiles) | \
- LC_ALL=C sort -u > all-distfiles; \
(cd $(srcdir) && git ls-files) | grep -v '\.gitignore$$' | \
grep -v '\.gitattributes$$' | \
LC_ALL=C sort -u > all-gitfiles; \
- LC_ALL=C comm -1 -3 all-distfiles all-gitfiles > missing-distfiles; \
+ LC_ALL=C comm -1 -3 distfiles all-gitfiles > missing-distfiles; \
if test -s missing-distfiles; then \
echo "The following files are in git but not the distribution:"; \
cat missing-distfiles; \
exit 1; \
fi; \
- if LC_ALL=C grep '\.gitignore$$' all-distfiles; then \
+ if LC_ALL=C grep '\.gitignore$$' distfiles; then \
echo "See above for list of files that are distributed but"; \
echo "should not be."; \
exit 1; \
fi \
fi
-CLEANFILES += all-distfiles all-gitfiles missing-distfiles
+CLEANFILES += all-gitfiles missing-distfiles
# The following is based on commands for the Automake "distdir" target.
distfiles: Makefile
@srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
@@ -235,7 +231,7 @@ config-h-check:
@cd $(srcdir); \
if test -e .git && (git --version) >/dev/null 2>&1 && \
git --no-pager grep -L '#include <config\.h>' `git ls-files | grep '\.c$$' | \
- grep -vE '^datapath|^lib/sflow|^third-party|^datapath-windows|^python'`; \
+ grep -vE '^datapath-windows|^lib/sflow|^python|^third-party'`; \
then \
echo "See above for list of violations of the rule that"; \
echo "every C source file must #include <config.h>."; \
@@ -256,7 +252,7 @@ printf-check:
@cd $(srcdir); \
if test -e .git && (git --version) >/dev/null 2>&1 && \
git --no-pager grep -n -E -e '%[-+ #0-9.*]*([ztj]|hh)' --and --not -e 'ovs_scan' `git ls-files | grep '\.[ch]$$' | \
- grep -vE '^datapath|^lib/sflow|^third-party'`; \
+ grep -vE '^datapath-windows|^lib/sflow|^third-party'`; \
then \
echo "See above for list of violations of the rule that"; \
echo "'z', 't', 'j', 'hh' printf() type modifiers are"; \
@@ -299,7 +295,7 @@ check-endian:
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1 && \
(cd $(srcdir) && git --no-pager grep -l -E \
-e 'BIG_ENDIAN|LITTLE_ENDIAN' --and --not -e 'BYTE_ORDER' | \
- $(EGREP) -v '^datapath/|^include/sparse/rte_'); \
+ $(EGREP) -v '^include/sparse/rte_'); \
then \
echo "See above for list of files that misuse LITTLE""_ENDIAN"; \
echo "or BIG""_ENDIAN. Please use WORDS_BIGENDIAN instead."; \
@@ -339,7 +335,7 @@ thread-safety-check:
if test -e .git && (git --version) >/dev/null 2>&1 && \
grep -n -f build-aux/thread-safety-forbidden \
`git ls-files | grep '\.[ch]$$' \
- | $(EGREP) -v '^datapath|^lib/sflow|^third-party'` /dev/null \
+ | $(EGREP) -v '^datapath-windows|^lib/sflow|^third-party'` /dev/null \
| $(EGREP) -v ':[ ]*/?\*'; \
then \
echo "See above for list of calls to functions that are"; \
@@ -468,11 +464,6 @@ install-data-local: $(INSTALL_DATA_LOCAL)
uninstall-local: $(UNINSTALL_LOCAL)
.PHONY: $(DIST_HOOKS) $(CLEAN_LOCAL) $(INSTALL_DATA_LOCAL) $(UNINSTALL_LOCAL)
-modules_install:
-if LINUX_ENABLED
- cd datapath/linux && $(MAKE) modules_install
-endif
-
dist-docs:
VERSION=$(VERSION) MAKE='$(MAKE)' $(srcdir)/build-aux/dist-docs $(srcdir) $(docs)
.PHONY: dist-docs