summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2017-10-30 09:44:52 -0700
committerBen Pfaff <blp@ovn.org>2017-10-30 09:44:52 -0700
commit45a9c31d5d915010deb6d8073fe22cf8c10f12de (patch)
tree096a21d67ba6defd5d2ab045746792e483a2e8f2 /Makefile.am
parenta05df205cdeb09ae644968f610365223f9b991ba (diff)
downloadopenvswitch-45a9c31d5d915010deb6d8073fe22cf8c10f12de.tar.gz
treewide: Get rid of "echo -n", and add a test to prevent regression.
"echo -n" is not POSIX and has spotty support in shells. CC: Timothy Redaelli <tredaelli@redhat.com> CC: Flavio Leitner <fbl@sysclose.org> Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 31d633179..5ceb3822c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -303,6 +303,17 @@ check-endian:
fi
.PHONY: check-endian
+ALL_LOCAL += check-echo-n
+check-echo-n:
+ @if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1 && \
+ git --no-pager grep -n 'echo'' -n' $(srcdir); \
+ then \
+ echo "See above for uses for \"echo"" -n\", which is non-POSIX"; \
+ echo "and does not work with all shells. Use \"printf\" instead."; \
+ exit 1; \
+ fi
+.PHONY: check-echo-n
+
ALL_LOCAL += thread-safety-check
thread-safety-check:
@cd $(srcdir); \