summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAnsis Atteka <ansisatteka@gmail.com>2018-01-15 16:18:30 -0800
committerAnsis Atteka <aatteka@ovn.org>2018-02-12 10:47:03 -0800
commit6feddcd5417d8b57a342f4378776f3b3751ea341 (patch)
treef435d371d609003fd8f1a253c648350858974000 /Makefile.am
parent6deeb55a3ec9357c42c21ca1582668136ed264c4 (diff)
downloadopenvswitch-6feddcd5417d8b57a342f4378776f3b3751ea341.tar.gz
poc: Introduce Proof of Concepts (Package building)
This patch sets up foundations for Proof of Concepts that simply materialize documentation into Ansible instructions executed in virtualized Vagrant environment. This Proof of Concept allows to easily build: 1. *.deb packages on Ubuntu 16.04; AND 2. *.rpm packages on CentOS 7.4. It also sets up DEB and RPM repository over HTTP that can be used to pull these openvswitch packages with apt-get or yum from another host. This particular Proof of Concept is intended to address following use-cases: 1. for new OVS users to see how debian and rpm packages are built; 2. for developers to easily check for packaging build regressions; 3. for developers to easily share their sandbox builds into QE setups (opposed to manually copying binaries); 4. for developers to add other Proof of Concepts that possibly may require full end-to-end integration with other thirdparty projects (e.g. DPI, libvirt, IPsec) and need Open vSwitch packages. Tested-by: Greg Rose <gvrose8192@gmail.com> Reviewed-by: Greg Rose <gvrose8192@gmail.com> Signed-off-by: Ansis Atteka <aatteka@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d397f652f..80a043531 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,6 +90,9 @@ EXTRA_DIST = \
build-aux/sodepends.py \
build-aux/soexpand.py \
build-aux/xml2nroff \
+ poc/builders/Vagrantfile \
+ poc/playbook-centos-builder.yml \
+ poc/playbook-ubuntu-builder.yml \
$(MAN_FRAGMENTS) \
$(MAN_ROOTS) \
Vagrantfile \