summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2019-01-10 15:23:46 -0800
committerBen Pfaff <blp@ovn.org>2019-01-11 08:45:07 -0800
commit75640c76656f286593a334f76119d7320377fdc6 (patch)
treeba225fdab14c1a4c0eb7b57fe9a410ec0bbd6ddb /Makefile.am
parent145a7e88bbc71b65f4c5015436c9f086a19b5a4a (diff)
downloadopenvswitch-75640c76656f286593a334f76119d7320377fdc6.tar.gz
python: Disable flake8 warning W504 "line break after binary operator".
OVS Python uses this style all over and I don't see a reason to avoid it. Acked-by: Numan Siddique <nusiddiq@redhat.com> Tested-by: Numan Siddique <nusiddiq@redhat.com> Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8408509c9..ff1f94b48 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -392,6 +392,7 @@ ALL_LOCAL += flake8-check
# E131 continuation line unaligned for hanging indent
# E722 do not use bare except, specify exception instead
# W503 line break before binary operator
+# W504 line break after binary operator
# F*** -- warnings native to flake8
# F811 redefinition of unused <name> from line <N> (only from flake8 v2.0)
# D*** -- warnings from flake8-docstrings plugin
@@ -401,7 +402,7 @@ ALL_LOCAL += flake8-check
# H233 Python 3.x incompatible use of print operator
# H238 old style class declaration, use new style (inherit from `object`)
FLAKE8_SELECT = H231,H232,H233,H238
-FLAKE8_IGNORE = E121,E123,E125,E126,E127,E128,E129,E131,E722,W503,F811,D,H,I
+FLAKE8_IGNORE = E121,E123,E125,E126,E127,E128,E129,E131,E722,W503,W504,F811,D,H,I
flake8-check: $(FLAKE8_PYFILES)
$(FLAKE8_WERROR)$(AM_V_GEN) \
src='$^' && \