summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2018-07-12 14:55:44 -0700
committerIan Stokes <ian.stokes@intel.com>2018-07-24 22:36:56 +0100
commit7a2ce387d8174b4b57133eb1f3689aa833e911c5 (patch)
tree32107434efd4bbbabfb7fe5e9e5cbd9ceef7629d /Makefile.am
parent773c3cb40f798df6152444fa968aba0679f624af (diff)
downloadopenvswitch-7a2ce387d8174b4b57133eb1f3689aa833e911c5.tar.gz
sparse: Add support for DPDK.
This allows netdev-dpdk.c to compile cleanly with sparse. Signed-off-by: Ben Pfaff <blp@ovn.org> Signed-off-by: Ian Stokes <ian.stokes@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fd6620a9b..788972804 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -296,7 +296,7 @@ check-endian:
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1 && \
(cd $(srcdir) && git --no-pager grep -l -E \
-e 'BIG_ENDIAN|LITTLE_ENDIAN' --and --not -e 'BYTE_ORDER' | \
- $(EGREP) -v '^datapath/'); \
+ $(EGREP) -v '^datapath/|^include/sparse/rte_'); \
then \
echo "See above for list of files that misuse LITTLE""_ENDIAN"; \
echo "or BIG""_ENDIAN. Please use WORDS_BIGENDIAN instead."; \