summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2020-06-17 14:22:47 -0700
committerBen Pfaff <blp@ovn.org>2020-10-16 19:22:24 -0700
commit8205fbc8f5e0ae5c85b9d1be2f5f53997ea4ff31 (patch)
tree670053b7fc93441fe351f3ba1ba2613a3e6b5474 /Makefile.am
parent807152a4ddfb89b65ef75c6b12937ecd68ea8cb3 (diff)
downloadopenvswitch-8205fbc8f5e0ae5c85b9d1be2f5f53997ea4ff31.tar.gz
Eliminate "whitelist" and "blacklist" terms.
There is one remaining use under datapath. That change should happen upstream in Linux first according to our usual policy. Signed-off-by: Ben Pfaff <blp@ovn.org> Acked-by: Alin Gabriel Serdean <aserdean@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 6981b943e..a3fbb15e2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -276,7 +276,7 @@ static-check:
fi
.PHONY: static-check
-# Check that assert.h is not used outside a whitelist of files.
+# Check that assert.h is not used (outside a small set of files).
ALL_LOCAL += check-assert-h-usage
check-assert-h-usage:
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1 && \
@@ -323,7 +323,7 @@ check-tabs:
if test -e .git && (git --version) >/dev/null 2>&1 && \
grep -ln "^ " \
`git ls-files \
- | grep -v -f build-aux/initial-tab-whitelist` /dev/null \
+ | grep -v -f build-aux/initial-tab-allowed-files` /dev/null \
| $(EGREP) -v ':[ ]*/?\*'; \
then \
echo "See above for files that use tabs for indentation."; \
@@ -336,16 +336,16 @@ ALL_LOCAL += thread-safety-check
thread-safety-check:
@cd $(srcdir); \
if test -e .git && (git --version) >/dev/null 2>&1 && \
- grep -n -f build-aux/thread-safety-blacklist \
+ grep -n -f build-aux/thread-safety-forbidden \
`git ls-files | grep '\.[ch]$$' \
| $(EGREP) -v '^datapath|^lib/sflow|^third-party'` /dev/null \
| $(EGREP) -v ':[ ]*/?\*'; \
then \
echo "See above for list of calls to functions that are"; \
- echo "blacklisted due to thread safety issues"; \
+ echo "forbidden due to thread safety issues"; \
exit 1; \
fi
-EXTRA_DIST += build-aux/thread-safety-blacklist
+EXTRA_DIST += build-aux/thread-safety-forbidden
.PHONY: thread-safety-check
# Check that "ip" is used in preference to "ifconfig", because