summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2014-08-04 11:11:40 -0700
committerBen Pfaff <blp@nicira.com>2014-08-04 11:11:40 -0700
commit837eefc76b3c79bb790a4c4c2d0a314d81b71a28 (patch)
treea1f69472e0cf641513506ac54eae1815e0ff0aa5 /Makefile.am
parentfa6395df71913c749f104978a736f238fb20bc08 (diff)
downloadopenvswitch-837eefc76b3c79bb790a4c4c2d0a314d81b71a28.tar.gz
Do not seemingly #include Linux-specific headers on other platforms.
Until now, the OVS source tree has had a whole maze of header files that make "#include <linux/openvswitch.h>" work OK regardless of platform, but this confuses everyone new to the tree, at first glance, and is difficult to understand at second glance too. This commit renames include/linux/openvswitch.h to datapath/linux/compat/include/linux/openvswitch.h without other change, then modifies the userspace build to generate a header that makes sense in portable Open vSwitch userspace from that header. It then removes all the remaining include/linux/* files since they are now unused. Signed-off-by: Ben Pfaff <blp@nicira.com> Acked-by: Jesse Gross <jesse@nicira.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f62198bca..eddacafd4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,7 @@ AM_LDFLAGS += $(PTHREAD_LDFLAGS)
endif
AM_CPPFLAGS += -I $(top_srcdir)/include
+AM_CPPFLAGS += -I $(top_builddir)/include
AM_CPPFLAGS += -I $(top_srcdir)/lib
AM_CPPFLAGS += -I $(top_builddir)/lib